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         Twin Tec 
User Instructions for 
TC88A Log Software 

CAUTION: CAREFULLY READ INSTRUCTIONS BEFORE PROCEEDING. NOT LEGAL FOR 

SALE OR USE IN CALIFORNIA OR ON ANY POLLUTION CONTROLLED VEHICLES. 

OVERVIEW 
TC88A Log software runs under Microsoft 

Windows XP/Vista/7. This software allows users of the 
TC88A ignition to view real time engine data during 
dyno tuning and to download and to display data 
logged by the unit including operating statistics and 
historical diagnostic codes. 

Using the software requires the Twin Tec USB 
Interface P/N 18014 for PC connectivity. The USB 
interface is compatible with Windows XP/Vista/7. The 
PC must have a free USB port. If you have an older PC 
without USB capability, you cannot use the software. 
For USB driver installation, COM port configuration, 
and module connections, please refer to the USB 
interface instructions. 

After TC88A Log is launched, the main screen 
appears blank. You have multiple display options. You 
can display real time engine data on an instrument 
panel type screen by using the View Real Time Data 
command on the View menu. You can display data 
logged by the TC88A unit on a chart recorder type 
screen. You can also view engine operating statistics 
logged by the TC88A unit. Data logged by the TC88A 
unit must be downloaded before it can be displayed, by 
using the Download Data From TC88A command on 
the Communications menu. Once data has been 
downloaded, it is automatically displayed on a chart 
recorder type screen. You can view the engine 
operating statistics by using the View Statistics 
command from the View menu. You can save this data 
by using the Save File command from the File menu. 
You can display a previously saved data file by first 
using the Open File command on the File menu and 
then using the View Chart or View Statistics 
commands on the View menu.  

A sample data file (Sample.log) is included in 
the program folder.  

PC REQUIREMENTS 
We recommend a laptop with Pentium processor 

and super VGA display (SVGA with 1024 x 768 pixel 
resolution) running Windows XP/Vista/7. Data display 
is graphics intensive and a high speed Pentium 
processor is recommended. Processors slower than 

300 MHz will exhibit sluggish program loading and 
response. The PC must have a available USB port.  

TC88A Log includes print commands to print 
downloaded data. The program has been tested with 
Hewlett-Packard laser and inkjet printers and Epson 
inkjet printers. We recommend using a color inkjet 
printer.   

SOFTWARE INSTALLATION 
The software is supplied in the form of a 

compressed file downloaded from our website. The 
installation process uses InstallShield. This industry 
standard installer is based the new Microsoft Windows 
Installer service that greatly reduces potential problems 
such as version conflicts and allows for application 
self-repair.  

Before proceeding with installation, shutdown any 
other applications that may be running. For Windows 
Vista, you must disable the User Account Control 
(UAC) during installation. If you are not familiar with the 
UAC, please refer to the Vista UAC Tech Note on our 
website's Tech FAQ for details. 

Use the Windows Explorer to run the setup.exe 
file downloaded from our website. InstallShield will install 
the software in an appropriate folder under Program 
Files. 

Once InstallShield has completed the 
installation, TC88A Log will appear on the Windows 
Start Menu. You can then launch it just as you would 
any other Windows program.  

TC88A Log requires the Monospace 821 BT 
fixed pitch printer font in order to properly align 
columns when printing. The Monospace 821 BT font is 
included in the distribution media and automatically 
copied to your Windows Fonts folder during 
installation. A backup copy is also placed in the 
program folder. If you accidentally delete this font, use 
the Install New Font command from the Fonts folder 
File menu. The filename associated with Monospace 
821 BT is monos.ttf. 

http://www.daytona-twintec.com/


 

 
Daytona Twin Tec, 240 Springview Commerce Dr., Bldg 1-J, Debary, FL 32713    TC88A Log 
(386) 304-0700   www.daytona-twintec.com  8/2021 

 Page 2 

TC88A CONNECTION  
Connect the USB interface. Turn the ignition key 

and engine run/stop switches on to provide power to 
the ignition. Do not start the engine. 

If the ignition module has been removed from 
the motorcycle, you can do bench top programming by 
using an adapter harness that includes a small 12 volt 
DC power supply. 

After the program is launched, the main screen 
appears. The program uses COM1 as the default port. 
In most cases, you will have configured the USB 
interface to use a different COM port, such as COM5. 
Use the Port Setup command on the Communications 
menu to select the correct COM port. The program will 
remember the new port setup. 

REAL TIME ENGINE DATA DISPLAY 
When the engine is running, you can display real 

time engine data on an instrument panel type screen 
by using the View Real Time Data command on the 
View menu. Please note that real time engine data 
cannot be directly saved by means of the TC88A Log 
program. However, this data is constantly being logged 
by the TC88A unit and can be downloaded (for 
example at the end of series of dyno runs).  

Real time engine data is displayed on an 
instrument panel type layout with round tach and 
speedometer gauges and bar graph type gauges for all 
other parameters. Diagnostic codes and system status 

messages are displayed in additional windows. If the 
engine is not running, most values will appear as zero 
or off. 

Displayed parameters include: 

RPM – engine crankshaft RPM (numeric value 
displayed beneath gauge) 

VSS – vehicle speed in MPH or KPH (numeric 
value displayed beneath gauge) 

MAP – manifold pressure in In-Hg or kilopascals 
(29.92 In-Hg or 101.3 kPa corresponds to sea 
level atmospheric pressure) 

BAT – battery voltage 

FRONT ADV, REAR ADV – ignition advance in 
degrees BTDC 

You can also select the vehicle speed, 
temperature, and pressure units used for real 
time engine data display and data logging chart 
display. Use the Units Selection command on 
the Edit menu. A dialog box will appear as 
shown in Figure 2. You can select miles per 
hour (MPH) or kilometers per hour (KPH) vehicle 
speed units, Farenheit (F) or Celsius (C) 
temperature units, and inches of mercury (In-Hg) 
or kilopascals (kPa) manifold pressure units. 
The program remembers the selections you 
have made. 

http://www.daytona-twintec.com/
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Figure 1 – Real Time Engine Data Display 

 

 
Figure 2 – Units Selection 

 

DATA LOGGING CHART DISPLAY 
You can also display data logged by the TC88A 

unit on a chart recorder type screen. Data logged by 
the TC88A unit must be downloaded before it can be 
displayed, by using the Download Data From TC88A 
command on the Communications menu. Once data 
has been downloaded, it is automatically displayed. 

The last data logged will appear at the right end of 
the chart. You can save the data by using the Save 
File command from the File menu after closing the 
chart display (data is not lost by closing the chart 
display). You can display a previously saved data file 
by first using the Open File command on the File menu 
and then using the View Chart command on the View 
menu.  

Please note that real time engine data cannot be 
directly saved by means of the TC88A Log program. 
However, this data is constantly being logged by 
theTC88A unit and can be downloaded (for example at 
the end of series of dyno runs).  

Note that TC88A data files use a .log extension. 
You should create a separate folder to store these 
files.   

You have a range of capabilities for analyzing 
downloaded data displayed in the chart recorder 
format. You can select two parameters for display. 

http://www.daytona-twintec.com/
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Trace 1 is displayed in red with its Y axis legends on 
the left side of the chart. Trace 2 is displayed in green 
with its Y axis legends on the right side of the chart. 

The X axis is always elapsed time. You can 
select from one of three time scales. You can use the 
scroll bar to move the chart display window in terms of 
elapsed time. If you hold the left mouse button down 
within the chart area, a cursor line appears. The exact 

values of the parameters displayed on trace 1 and 
trace 2 and the elapsed time appear in windows above 
the chart. If you want to analyze the elapsed time 
between two events (for example the time required to 
accelerate from 0 to 60 MPH), you can move the 
cursor to the first event and then click on the Reset 
Time Display button. You can print the displayed chart 
to any Windows printer by clicking on the Print button 
(a color inkjet printer is recommended for best results).

Figure 3 – Data Logging Chart Display 

 
Data parameters include: 

RPM – engine crankshaft RPM 

VSS – vehicle speed in MPH or KPH 

MAP – manifold pressure in In-Hg or kilopascals 
(29.92 In-Hg or 101.3 kPa corresponds to sea 
level atmospheric pressure) 

SPARK ADV – front cylinder ignition advance in 
degrees BTDC 

BAT – battery voltage 

Additional data is displayed at the lower right 
side of the screen. This data includes: 

Diagnostic Code – normally blank unless a 
diagnostic code is set. Refer to the TC88A 
installation instructions for details. 

Engine Status – Off or Running. 

http://www.daytona-twintec.com/
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Log Interval – the actual data logging interval in 
seconds 

The TC88A data buffer stores the last 4000 data 
points. With a nominal data logging interval of 0.50 
seconds, this corresponds to 33 minutes of data. You 
can set higher or lower data logging intervals by means 
of the Edit TC88A Parameters command on the Edit 
menu. Data logging intervals of 0.5-1.0 seconds are 
suitable for on-road tests; a shorter interval of 0.10 
seconds is recommended for dyno tuning. After you 
enter a new data logging interval, click on Upload to 
TC88A. 

You can clear the data within the TC88A by 
using the Clear TC88A Data Buffer command from the 
Communications menu. If you change the data logging 
interval, you should also clear the TC88A data buffer. 

OPERATING STATISTICS 
You can also display engine operating statistics, 

including historical diagnostic codes, logged by the 
TC88A unit. Data logged by the TC88A unit must be 
downloaded before it can be displayed, by using the 
Download Data From TC88A command on the 
Communications menu. Once data has been 
downloaded, you can use the View Statistics command 
from the View menu. You can save the operating 
statistics data by using the Save File command from 
the File menu. Please note that data for historical 
diagnostic codes is not saved. You can display a 
previously saved data file by first using the Open File 

command on the File menu and then using the View 
Statistics command on the View menu. 

Note that TC88A data files use a .log extension. 
You should create a separate folder to store these 
files. 

The data is fairly self-explanatory. Total hours 
represents the total time that the engine was running. 
ID represents the firmware identification. This field 
typically includes the manufacturer (Twin Tec), model 
number, program revision and author's initials, and 
date. Note that the date is not a manufacturing date 
code, just the date for the particular firmware release.  

Elapsed time is displayed for 13 RPM bands 
from idle to 6999 RPM. Note that elapsed time data is 
rounded off during each engine run, so the sum of the 
elapsed time figures may not precisely match the total 
hours. The program also displays the maximum engine 
RPM, time at the RPM limit (in seconds for better 
resolution) and the number of engine starts.  

Clicking on the Print Statistics button prints a 
report. When you click on this button, a small data 
entry screen pops up and allows you to add a serial 
number or comment that will appear on the printout. 
You can also use the Print command from the File 
menu.  

 

Figure 4 - Operating Statistics Display 
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Figure 5 - Operating Statistics Histogram Chart 

 

 

Any historical diagnostic codes logged by the 
TC88A are listed along with the number of trips (engine 
start cycles) since the individual code was last logged. 
Codes are automatically cleared after 50 trips.   

Customers are often confused about the 
meaning of the term “trips.” This is an industry 
standard terminology. If a code shows 40 trips, it 
means that the code was set 40 engine start cycles 
ago, not that the code has been set 40 times. 

Refer to the TC88A instructions for further 
information about diagnostic codes. You can clear 
historical diagnostic codes by using the Clear Historical 
Diagnostic Codes command from the Communications 
menu. 

The elapsed time data in the various RPM 
bands can be displayed in the form of a histogram 
chart by clicking on the Histogram button. 

Color coding of the bars helps to interpret the 
data. The idle RPM band is blue, normal operating 
RPM bands are green and high RPM bands are yellow 
and red. The chart is automatically scaled for best 
display. You can print the chart along with a complete 
statistics report by clicking on the Print Chart button. 

 

IMPORTING DATA INTO EXCEL 
Data files saved from TC88A Log are in comma 

delimited ASCII format. You can easily import a data 
file into other programs such as Microsoft Excel for 
further analysis. You can also view data files with a text 
editor such as Windows WordPad. To import a data file 
into Excel: 

1. Start Excel. In the File Open dialog box, select 
Files of type: All Files (*.*). Then browse for the 
data file. 

2. The Text Import Wizard appears. For step 1, select 
delimited file type. For step 2, select comma 
delimiter. For step 3, select general column data 
format. Then click on Finish. 

3. You can then format the data and save the 
spreadsheet as an Excel file. 

TROUBLESHOOTING FLOWCHART 
Follow the troubleshooting flowchart shown on 

the next page. Experience has shown that most 
communication problems are user error or PC 
compatibility issues. 

 

http://www.daytona-twintec.com/
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Troubleshooting Flowchart 
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